5
Vote

(Suggestion) Having namespace and class the same. SQLinq.SQLinq is wonky

description

Even resharper can't figure it out, it it says "namespace 'SQLinq' cannot be used with type arguments" until you manually put the using SQLinq; at the top.
 
The SQLinq class might better be named Query or something.
 
So
 
        var query = from d in new Query<Something>()
                    where d.Key != Guid.NewGuid()
                    select d;
 
       - or -
 
        var query = from d in new SqlQuery<Something>()
                    where d.Key != Guid.NewGuid()
                    select d;
 
vs
 
        var query = from d in new SQLinq<Something>()
                    where d.Key != Guid.NewGuid()
                    select d;

comments

salar2k wrote Jun 26, 2012 at 12:30 PM

I agree with this comment, just change the namespace. that would be enough.

wrote Dec 17, 2012 at 8:28 AM

wrote Feb 14, 2013 at 6:10 PM

wrote Apr 27, 2013 at 5:56 PM

crpietschmann wrote Oct 19, 2013 at 12:31 AM

I'm thinking about this, but it would be a breaking change to make.

wrote Nov 26, 2013 at 2:49 PM